何年も前にメールで営業した会社から電話があった。
PHP4から突然PHP5になったためosCommerceが急に動作しなくなったという。
何かのときに役立つと考えて私からの営業メールを大切に保管していたそうだ。
ありがたいことだ。

PHP4で動作しているosCommerceはかなりたくさんあるのかもしれない。
何点か修正すれば問題なく動作する。
最近、お客様と話をしていて問題になるのはいま使っているosCommerceにお金を使っていいかどうかということ。
現在、利用している日本語版osCommerceのほとんどはPHP5.4になると動作しなくなる。
そのまま利用を続ける方と新しいショッピングカートに移行される方に分かれるだろう。
修正して動作するうちは使い続けるのがもっとも負担が少ないような気がする。
osCommerce2.3.3に日本語ファイルが用意できれば問題なくなると思うが、
すでにその需要はないのかもしれない。
 

%d人のブロガーが「いいね」をつけました。