お客様の依頼を受けてWordPressをインストールしようとしたが、
以下のようなログインエラーが出て、ログインできない。
「エラー: WordPress は Cookie を必要としますが、あなたのブラウザーは Cookie をサポートしていないかブロックしています。」と表示される。
検索しても同じような情報は見つからなかった。
ブラウザのキャッシュとクッキーを削除して再起動してアクセスしてみるが、結果はエラー。クッキーを受け付けるようブラウザにサイトのURLを登録してみるがダメ。
しかし、テストスクリプトを作って実験してみるとなぜか書き込めた。
同じスクリプトをログイン用のファイルにはりこんでみたがうまくいかない。クッキーは20行目あたりでセットしているが、その前でwp-config.phpを読み込んでいた。ためしに、このファイルの文字コードをUTF-8からUTF-8Nにしたら、ログインできた。

%d人のブロガーが「いいね」をつけました。