きっと、これはZen Cartの問題ではなくPHP5.3の制限によるエラー表示があるのでしょう。

PHP5.3には推奨されない機能があり、それらを使用するとエラーが山ほど表示されます。

PHP 5.3.x で推奨されない機能

http://www.php.net/manual/ja/migration53.deprecated.php

自分のソースコードの中では使用していなくてもPEARを利用していると同じようにエラーがでることがあります。

ereg関数などはたくさん使用されていると思いますが、これを書き直すのは正規表現に慣れていないと面倒です。

そこで、

php.iniでは、

error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

またはプログラム内で

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);

とするとエラーが消えると思います。
(私はまだ試していません)

%d人のブロガーが「いいね」をつけました。